Материал: Базовые технологии в табличном процессе Exel - Учебное пособие (Ильина О.П.)

Предмет: Информационные технологии

Просмотров: 3650


Ведомость расчетов с организациями

Лист Расчеты содержит начальное сальдо (остаток) и результаты текущих расчетов с организациями. Предусмотрено выделение цветом отрицательного и положительного итога расчетов.

1. Выделить блок Организации команда Правка, Перейти.

2. Выполнить команду меню Правка, Копировать. Вставить блок ячеек из буфера обмена на лист Расчеты команда меню Правка, Специальная вставка, Вставить связь  для обеспечения синхронности нормативно-справочной информации.

3. Сформировать шапку таблицы (рис. 45).

 

 

Название

Банковские     реквизи-

ты

Сальдо

По       посту-

плению

По       от-

грузке

Итого

АО Сигнал

р/с 123984766563455

в          АКБ    Балтийский банк

-12000

 

 

 

Магазин № 5

р/с

4433554656546564

-32000

 

 

 

 

Название

Банковские     реквизи-

ты

Сальдо

По       посту-

плению

По       от-

грузке

Итого

 

в          АКБ    Санкт-

Петербург

 

 

 

 

ПО      Севме-

бель

р/с 123984766563443

в АКБ Петровский

20000

 

 

 

Универмаг

ЦФТ

р/с

1236546587687876    в

АКБ Энергобанк

 

 

 

 

 

Рис. 45 Расчеты с поставщиками и покупателями товаров

 

4. Для каждой организации автоматически вычисляются  стоимость полученных и отгруженных товаров на основании информации базы данных:

По поступлению:

=СУММЕСЛИ(Организация;$A2;Итого_поступление)

По отгрузке: =СУММЕСЛИ(Организация;$A2;Итого_реализация)

где $A2 адрес ячейки, содержащей название организации на листе Расчеты.

Организация, Итого_поступление,  Итого_реализация    имена блоков, включающие ячейки, листа Движение.

Размножить формулы по всем ячейкам столбцов По поступлению; По отгрузке.

5. Ввести формулы расчета текущих итогов расчетов с организациями:

Итого  = Сальдо + По отгрузке По поступлению

Сумма в столбце По отгрузке берется со знаком плюс, а сумма в столбце По поступлению – со знаком минус. Таким образом, организациядолжник имеет положительный итог, а организация, которой должны мы, отрицательный итог. Размножить формулы по всем   ячейкам столбца Итого.

6. Выполнить условное форматирования ячеек столбца Итого.  Если остаток меньше 0, использовать зеленую заливку, если остаток больше или равен 0 – голубую заливку фона ячеек.

7. Ввести начальные остатки (Сальдо) по расчетам с организациями (положительное число долг организации нам, отрицательное число наш долг организации). Остальные столбцы таблицы не заполнить (см. дальше).

8. Вычислить итоги по столбцам Итого; Сальдо; По отгрузке; По поступлению.

9. Создать именованный блок Итого,   который содержит ячейки одноименного столбца (кроме заголовка).

таблицы, включая заголовки столбцов.

11.       Скрыть введенные формулы.

12.       Защитить информацию рабочего листа от изменений.

 


Загрузка...