Материал: Базовые технологии в табличном процессе Exel - Учебное пособие (Ильина О.П.)

Предмет: Информационные технологии

Просмотров: 3663


Оборотная ведомость движения товаров

Лист Итоги содержит итоговые данные о начальном остатке, движении и текущем остатке товаров на складе в стоимостном и натуральном выражении. Содержание ячеек листа Итоги синхронизированы с состоянием базы данных Движение товаров на складе. Количество строк таблицы соответствует номенклатуре товаров склада.

Информационная технология  создания листа Итоги

1. Выделить блок Товары и скопировать его в буфер обмена команда Правка, Копировать. Вставить блок ячеек из буфера обмена на лист Итоги,  начиная с ячейки А1 команда Правка, Специальная вставка, Вставить связь.

2. Сформировать шапку таблицы (рис. 44).

3. Для ячеек столбца Остаток на конец ввести формулу вида:

Остаток на конец=Остаток на начало + Поступление Реализация

4. Выполнить условное форматирование ячеек столбца Остаток на конец: если остаток товара равен 0, желтая заливка фона, меньше 0 – красная заливка фона.

5. Для ячеек столбцов Поступление и Реализация ввести формулы расчета итогов по поступлению и реализации товаров на основании данных движения:

G2:       = СУММЕСЛИ(Товар;$A2;Поступление)

I2:        = СУММЕСЛИ(Товар;$A2;Реализация)

где $A2 адрес ячейки, содержащей код товара (для первой записи);

Товар, Поступление, Реализация    имена блоков ячеек листа Движение.

Можно сначала задать формулу для ячейки G2, а затем ее скопировать в ячейку I2 и отредактировать – изменить имя блока (Поступление заменить на Реализацию). Для этого следует задать адрес ячейки A2 как абсолютную ссылка по координате столбца.

 

 

Формулы размножить по всему диапазону ячеек столбцов Поступление, Реализация.

6. Задать формулы расчета стоимостных показателей для ячеек столбцов Остаток на начало, руб.; Поступление, руб.; Реализация, руб; Остаток  на конец, руб.:

Остаток на начало, руб. = Остаток на начало * Цена

Поступление, руб. = Поступление * Цена

Реализация, руб. = Реализация * Цена

Остаток на конец, руб. = Остаток на конец* Цена

Можно сначала задать формулу для ячейки F2: =$D2*E2, затем скопировать ее в ячейки H2, J2, L2. После этого размножить все формулы по столбцам.

7. Вычислить итоги по столбцам: Остаток на начало, руб.; Поступление,

руб.; Реализация, руб.; Остаток на конец, руб.

8. Ввести произвольные значения начальных остатков товаров в количественном выражении.

9. Создать именованный блок Итоги  для всей таблицы, включая заголовки столбцов.

10.       Создать именованный блок Остаток_на_конец для одноименного столбца

11.       Скрыть введенные формулы.

12.       Защитить информацию рабочего листа от изменений.